A77

texascbx

Veteran
Jul 10, 2010
Canton Texas
Ricky
Got a A65 from Bedfords a couple of weeks ago and it was just not what I wanted so sent it back and got a SLT-A77. Have not had time to master all those controls yet but when I do, I will post a few images.:biggrin:
 

flysurfer

Hall of Famer
Aug 31, 2011
Interesting. I have been observing Sony for quite some time, so I'm always looking forward to first-hand info. So far, I'm not convinced by the merits of the 24 MP sensor in the NEX 7 and especially the A77, where it's losing at least another 1/3 EV of light due to the mirror. I have experience with the A55, it's a nice camera but way too noisy at ISO 1600. I guess I'm spoiled by the X100 in this regard.
 

soundimageplus

Top Veteran
Jul 6, 2010
Got a A65 from Bedfords a couple of weeks ago and it was just not what I wanted so sent it back and got a SLT-A77. Have not had time to master all those controls yet but when I do, I will post a few images.:biggrin:
Enjoy. I've had mine for a few weeks and its a very impressive camera.
 

texascbx

Veteran
Jul 10, 2010
Canton Texas
Ricky
One of the reasons I sent the A65 back is my Tamron 18-250. It always focused lighting fast and was dead accurate 98% of the time on a33. On the A65, it was about 20% slower focusing and the focus was off. So I thought either the lens matched up perfect with my A33 and was off on the A65, or the A65 was just bad. Since the A77 has a lens adjustment, maybe it would be better. Just saying it could be the lens though. Also the A65 takes about five to ten seconds to shut down. Once it never did shut down and drained the battery completely. Aggravating to grab your camera and find it completely dead for no good reason. I checked the firmware and it was 1.03.

Also could be the lens is just not up to snuff for so many megapixels too so I will find out soon. I may sell the lens and get the Sony 18-250 since the camera corrects for PF, CA and distortion, but only with certain Sony lens.
 

gsaronni

Regular
Oct 12, 2010
One of the reasons I sent the A65 back is my Tamron 18-250. It always focused lighting fast and was dead accurate 98% of the time on a33. On the A65, it was about 20% slower focusing and the focus was off. So I thought either the lens matched up perfect with my A33 and was off on the A65, or the A65 was just bad. Since the A77 has a lens adjustment, maybe it would be better. Just saying it could be the lens though. Also the A65 takes about five to ten seconds to shut down. Once it never did shut down and drained the battery completely. Aggravating to grab your camera and find it completely dead for no good reason. I checked the firmware and it was 1.03.

Also could be the lens is just not up to snuff for so many megapixels too so I will find out soon. I may sell the lens and get the Sony 18-250 since the camera corrects for PF, CA and distortion, but only with certain Sony lens.
Thanks for telling us your experiences with SLT. And let us know how good is the 18-250, it is a lens sometimes I miss when travelling when only when lens and my A700
 

texascbx

Veteran
Jul 10, 2010
Canton Texas
Ricky
Lens works pretty good with the A77. Must have been the A65. I have to do some work on the images since the highest jpeg setting results in a file of around eighteen Mb. I see why some people shoot only jpeg with this thing because there is a lot of info there and RAW software is not caught up yet.
 

Latest threads

Top Bottom