Feedback Google Photos links behaving oddly

Kevin

Code Monkey 🐒
Nov 3, 2018
104
Pennsylvania, USA
Hhhhhmm..... nothing has changed recently but I'll take a look. There may be something going on with how remote images are cached.
Confirmed: It's related to how remote linked images are cached locally. The add-on we are using here at Cameraderie is not the same one that is available publicly & in use by other sites; the purpose of the add-ons are the same but the coding of them is completely different.

I'll go through the code to see what's going in. My guess is that it's failing a file type check so it thinks it's not an image file even though it really is.
 

phigmov

Top Veteran
Mar 23, 2015
104
I'll go through the code to see what's going in. My guess is that it's failing a file type check so it thinks it's not an image file even though it really is.
Awesome - thanks!

Yeah, I always thought it was both odd and annoying that The Goog decided not to do the decent thing with image-links and put the extension on the end. Always marvelled at the forum softwares ability to go "Oh, its Google... OK, I'll jump through some hoops to parse this link so you don't have to".
 

Kevin

Code Monkey 🐒
Nov 3, 2018
104
Pennsylvania, USA
Whoops, almost forgot to circle back to this one. I've patched the code with a quick fix that should display the image 'as-is' if it can't figure out if it's a good image to cache or not. I've got a cleaner fix being worked on at the test site but I need to torture test it yet before moving over to the production site.



For the geek crowd.... Google's weird, the real image info (name, mime type) comes over in the headers of the request. Why not just serve the file directly?
 

Latest posts

Latest threads

Top Bottom