Micro 4/3 Micro 4/3 samples

theoldsmithy

Hall of Famer
Location
Cheshire, England
Real Name
Martin Connolly
Hi, inspired by IVN's work here I've got a 25mm f1.4 CCTV lens plus m43 adapter. When I fit it the camera obviously 'sees' through the lens as the exposure varies when I turn the aperture ring or point it at brighter subjects. However the screen and EVF stay resolutely black. What am I doing wrong? I have a Sigma MF 28mm lens which works fine with an adapter.
 

IVN

Veteran
Hi, inspired by IVN's work here I've got a 25mm f1.4 CCTV lens plus m43 adapter. When I fit it the camera obviously 'sees' through the lens as the exposure varies when I turn the aperture ring or point it at brighter subjects.
Just to make sure, because the 25/1.4 is quite odd in this regard, are you turning the right ring? The aperture ring is the one close to the front of the lens, while the focus ring is close to the body.
However the screen and EVF stay resolutely black. What am I doing wrong? I have a Sigma MF 28mm lens which works fine with an adapter.
My first thought is that the aperture is almost completely closed (these CCTV lenses have the feature/bug that you can close the aperture almost completely), which then results in a black LCD/EVF. And if you are turning the focusing ring, which is where all other lenses have their aperture ring, the LCD/EVF stays black, because the aperture remains closed.

My suggestion: unscrew the lens, open the aperture all the way and screw the lens back on again. But be careful that you don't close the aperture in the process, which has happened to me a number of times.
 

Latest posts

Latest threads

Top Bottom