Nik Software Update

Jan 31, 2011
164
Newcastle, Australia
Sue
Wow, seems that the people having issues are all Windows users. I use mac. No problems.

Peter, I sent an email saying, hey I bought this at $149 and I feel like I ought to be able to have access to the new plugin, can you help, and they sent me a link to a completely new download. I installed it over the top of the other and its all good.
 

twokatmew

Regular
Aug 19, 2012
68
Lansing, Michigan, US
Margaret
Google's blog has said to download the trial, install over top of your existing software and all will be well. Worked for me. No need to wait for Google to send you a whole new plugin. I'm a Windows user, no prob here. :)
 

pniev

Student for life
May 13, 2013
124
Same here. I sent an email and got a response within a few hours. Everything works fine and no need to reenter activation codes. This also means that installing the trial version is not the way to go.

Wow, seems that the people having issues are all Windows users. I use mac. No problems.

Peter, I sent an email saying, hey I bought this at $149 and I feel like I ought to be able to have access to the new plugin, can you help, and they sent me a link to a completely new download. I installed it over the top of the other and its all good.
 

Tilman Paulin

Top Veteran
Nov 15, 2011
69
Vancouver B.C.
Tilman
I'm using Windows 7 and the new plugin just appeared 'magically'.
Works fine, but I'd personally prefer to be able to choose if I want to upgrade a running system or not.
Ah well, still nice to get added functionality as a post-purchase-service... :)
 
Jan 31, 2011
164
Newcastle, Australia
Sue
I'm a Mac user Sue ! :mad:
You know what? I had not started aperture since I installed them, and be damned if it didn't start itself up, when I plugged my iPhone in for charging.... and all kinds of weird shit happened. I've already decided I don't really want aperture so I'm going to drop it (again) and revert to iPhoto and CS5 (again). Those work, at least. I only use iPhoto for management anyway.
 

Ripleysbaby

supernatural anesthetist
Sep 9, 2011
123
Cumbria UK
Garry
Yesterday I noticed my collection had been upgraded to include Analog. I wasn't asked if they could install it, it was just there in the list of plug ins.
Since then Aperture (and the Nic plugins) have been misbehaving and i am not happy :mad:
Still having Aperture crashes since the Analog install. And still no joy with Nik Google re problem.
A possible fix could work but as i have forgotten the download email address and lost record of licence key they wont send me download link.
They have all the other details like name address date of purchase bank account and sort code numbers.
I fail to see a problem. They knew of my ownership because they sent me the naff Analog update in the first place.
I have had problems with other programs in the past. Lost a load of Viewranger maps one time ! £££££ One email They looked up bank payment and sent a link within half hour. Good service from Topaz too after I messed up.
Come on google. You caused my problem. Please fix it
 

Gubrz

O.* Gonzo's & Bentley's Dad
Jun 5, 2012
103
Austin, TX
Eliot
I installed analog, it turned everything into a trial. Emailed them... Almost a week later they reply. I had to reinstall everything and lost my presets(when everything flipped to trial unexpectedly)


Sent from my iPad using SeriousCompacts mobile app

Oh, also, I can edit anything just fine now, but once I hit save, my upper window will never change from the photo I had edited. I have to close and reopen after every edit in order to see any photo larger than the little previews........
 

Isoterica

Hall of Famer
Dec 6, 2011
123
Never got to the computer formatting part, however, I did get a response on the Nik software and after I mailed them my serial numbers they were able to identify me and they sent me a link for a full download. It would seem I fell off the system and my email and name brought up nothing. It all works..
 

Latest posts

Latest threads

Top Bottom