Canon Photos turn all red

João Estêvão

New Member
May 1, 2013
Good afternoon,

I have tried several camera modes and all photos turn red. I have to correct them all in lightroom... I may have changed some settings but after searching I can't find anything in order to correct that rediness.

Is a camera problem?
Can you help me?


Appreciated.
Cumpz.
 

bartjeej

Hall of Famer
Nov 12, 2010
bart
Did you check the white balance? That's the only thing I can think of, in terms of settings, that would change your photos' colours...
 

João Estêvão

New Member
May 1, 2013
Sample photo?

From what you are saying, it sounds like a bad camera, but hard to diagnose without seeing it.
There's two photos. One taken when the sun was going down




This was inside a restaurant near the exit door


I think these were taken using AV mode. Actually, I'm using AV mode with correction of contrast in Neutral.
In auto mode, colors are more natural... That's why I was saying that I may have change some settings...

Thanks
 

João Estêvão

New Member
May 1, 2013
Sample photo?

From what you are saying, it sounds like a bad camera, but hard to diagnose without seeing it.
Usually I use white balance according to the place I'm taking pictures. I was looking for the current settings and the last one was set for sunny days and I already adjusted in order to be "cooler".
 

bartjeej

Hall of Famer
Nov 12, 2010
bart
I don't know how the G1X works, but is there some white balance shift setting, that allows you to make finer adjustments than just general white balance settings? If so, you should see an amber/blue axis and a red/green axis, and your choices here will be applied to whichever white balance mode you're in. In auto mode, the white balance adjustments might not be applied, which would explain why you're getting normal images.

I edited your photo in lightroom and it seems a good amount of more blue and a lot more green in the white balance adjustments fix your image nicely.
 

João Estêvão

New Member
May 1, 2013
I don't know how the G1X works, but is there some white balance shift setting, that allows you to make finer adjustments than just general white balance settings? If so, you should see an amber/blue axis and a red/green axis, and your choices here will be applied to whichever white balance mode you're in. In auto mode, the white balance adjustments might not be applied, which would explain why you're getting normal images.

I edited your photo in lightroom and it seems a good amount of more blue and a lot more green in the white balance adjustments fix your image nicely.
Thanks :)
That's what I meant in the last post. I adjusted to the blue axis side... in order to be more cold than warm pic. But I will try to understand why is this thing happening.

Cumpz
 

ean10775

All-Pro
Feb 13, 2013
Cleveland, Ohio
Eric
I would reset the camera to factory settings and shoot using AWB outdoors in daylight and see if the problem still occurs (you could test in indoors as well, keeping in mind that AWB doesn't always do the best job with handling different temperatures of incandescent lighting).
 
May 6, 2013
Usually I use white balance according to the place I'm taking pictures. I was looking for the current settings and the last one was set for sunny days and I already adjusted in order to be "cooler".
Hey if you cannot find out the setting that you might have check just don't experiment with it anymore as the things might go bad. Get help from some expert.
 

Latest posts

Latest threads

Top Bottom