Plugin Issues with LR4.

Duane Pandorf

Top Veteran
Apr 25, 2011
103
Western NC
I thought I'd switch from Aperture 3 as I like a couple modules LR has that Aperture doesn't. Lens Correction and noise correction. However, my Nik plugins don't work unless I install PS. (I installed the PS trial version to test this.). So I deactivated LR 4 and have a refund being processed.
 

Duane Pandorf

Top Veteran
Apr 25, 2011
103
Western NC
SEP and Viveza are working fine for me. There are LR4 updates on the NIK website.
Hi Ollie, as part of my trouble shooting I downloaded the latest updates from Nik. I also deleted my preferences and reinstalled LR 4 and the plugins but still no go. Iwas finally able to get them to work from the Edit With menu from inside LR4 when installed the trial version of PS CS5.

Btw, I had already contacted NIK and they too advised that I try the remedy I mentioned above as they have been getting plenty of complaints from others.

The plugins worked as advertised in the beta version of LR4.

As a side note, I was probably going to get frustrated with LR4's catalog mgmt system as I didn't realize how flexible Aperture's really is.

Ive also been spending time over at the ApertureExpert Tips - ApertureExpert.com site and have some great tips on improving the way Aperture works on my machine.

I hope that the Aperture 4 will add a couple things that I now use external apps for to finish my images, like BorderFX Plug-ins to add my Copyright/signature and another app I use to adjust perspective which LR4 has in its Lens Correction module, I think that's where it is.
 

pdh

Legend
Jan 2, 2011
123
It seems that Adobe have acknowledged this (the plugin issue) as a problem - which they haven't yet regarding the speed

Wonder if it's worth a mod splitting off the plugin problems to a new thread?
 

bilzmale

Super Moderator Emeritus
Jul 17, 2010
124
Perth, Western Australia
Bill Shinnick
A post over on mu-43 links to a post on Adobe forum suggesting a registry hack for Win 7 users. I offer this without testing as I've not had any problems (possibly because I have CS5).

LINK: scroll down to post 224 for the details. I'm not recommending this as I suspect official fixes will come in due course. Of course back up your registry first if you try it.
 

adanac

Veteran
Sep 30, 2011
103
Vancouver, BC
Adding a registry entry isn't a big deal, but if one isn't comfortable with that, for both Windows and Mac OS X users downloading and installing Photoshop CS5 on a trial basis will solve the problem and allow your Nik and other third party LR4 plugins to operate once more.

Note that you don't even have to run Photoshop once, simply installing it will do the job. When Adobe releases the update to LR4 you'll be able to uninstall Photoshop.

I've tested the workarounds on both Windows and Mac machines with complete success. LR4 seems a little slower on my OS X machine than before but I like the results I'm getting and the performance difference is largely irrelevant to how I work.
 

krugorg

All-Pro
Sep 26, 2011
123
Minnesota USA
Kyle Krug
Yeah, I ran into the same thing with my LR4 upgrade and Nik. I found the regedit fix on the web and that did work for me. Weird deal, but I am now having a lot of fun with the new LR.

The main reason I use LR versus Aperture is that I can use it (one license) on both my macbook air and my home windows work station. It is nice, for me, to be able to have one interface on both OS platforms.
 

Latest posts

Latest threads

Top Bottom