Sony Sony RX100V Aperture stuck


New Member
My Sony RX100V seems to have a stuck aperture. As in, it's stuck wide open. I'd researched this before, and someone suggested resetting the camera, and that seemed to work. But it's back again, and a reset and even initializing the camera didn't fix it.

In full manual, if I adjust the aperture, it doesn't change the exposure. Oddly, it acts like it's in aperture priority, even though the aperture doesn't ever seem to change. Depth of field never gets any deeper or shallower by changing the aperture ring. The exposure's still the same, regardless. Either the aperture is stuck or the camera is compensating somehow. It could be my unfamiliarity with Sony cameras, this is my first Sony still camera (I'm a Nikon guy).

Do any of you have any idea why? Is it a simple operator error, or is this something I need to send my camera in for?



Hall of Famer
I have ver IV. I don't use full manual, mostly use aperture priority. Have you taken the photo or is it on the lcd? LCD might compensate the lower light. There is an exposure compensation but it should not adjust it normally. Also have you tried to change it in Aperture mode if the aperture changes? Usually the dof is not that shallow compared to dslrs. The other choice might be return or send for repair.


New Member
Thanks, Serhan. I know the DOF isn't the same, but there should be a notable difference between f/1.8 and f/11. I've tried in Manual, Aperture Priority, Shutter Priority. No change. Images look the same (I shot them, wondered about the LCD, but there's no difference). EXIF shows what I set it at. I've locked ISO, so that's not Auto. Don't know what else it could be? I'm hoping it's operator error, there's a lot of complex stuff with this camera, even compared to professional DSLRs.

Latest posts

Latest threads

Top Bottom