Sony Tried a 'Faster' SD card, a little disappointing in the A7RIII, VERY odd results in the A7 IV.

On a quest to try and improve the hit rate on my A7RIII. One issue is hesitation between shots during a burst, some of which is due to the camera slowing when the buffer is full. I hoped a card with a faster write speed would make a noticeable difference over the Sony Tough 277/150. I decided to try a Kingston Canvas React 300/260, which gets excellent reviews and is less costly than the faster Sony, just in case it turned out to be a waste.

Testing was simple. I activated the buffer display and pressed the button until the line disappeared and 'slow' appeared, then timed how long it took to clear the buffer. I ran this test with both cards several times and came up with pretty much the same result each time:
  • The Sony 128G 277/150: 27 shots to full, and a touch under 15 seconds to clear.
  • The Kingston Canvas React 128G 300/260: 28 shots to full, a touch under 14 seconds to clear.
So...meh. Certainly not enough of an improvement to make any kind of noticeable difference in use. The 'slower' Sony tough card is $69, the Kingston is $82. I'd rather have the 'slower' Sony Tough card. No idea if the faster Sony Tough would make a difference, but not interested in spending that much more money to find out.

I might try it in the A7IV to see if the newer/faster processer can put the card to better use. If not, I'll carry the Kingston as a spare. I have more trust in the Sony cards.

If anyone read the first version, please read this again.

This is weird. The first attempts on the A7 IV had the Kingston Canvas React performing WAY worse than even the 277/150 Sony. Where the Kingston had slightly better performance than the slower Sony in the A7RIII, it took twice as long to clear as the Sony when testing the A7 IV.

In the A7 IV, both cards allowed 19 images before hitting slow, but where the Sony cleared in just over 6 seconds the Kingston took almost 13 seconds to clear.

FWIW, I used the same lens as the A7RIII test just to avoid another variable. The burst rate was set to High, which on the A7 IV in RAW means 6 FPS.

I was pretty disappointed with those results and had given up. Before I put the camera away I decided to do it again. Now, the Kingston is clearing in half the time of the Sony. Instead of almost 13 seconds like the first test (twice as slow), it's now clearing in just under 4 seconds (twice as fast). That is a substantial improvement from the first test, and almost double the speed of the Sony.

I retested the A7RIII and there is no change.

For the record, I changed nothing. Everything was exactly the same. Also, I reformatted both cards on every single test for both cameras.

I have no explanation. These tests are inconclusive. I'd delete this entire thread if it didn't already have reactions. If anyone has any ideas I'd love to hear them! :hmmm:
Last edited:

John King

Member of SOFA
Beaumaris, Melbourne, Australia
John ...
Read/Write speeds advertised for SD cards are almost imaginary figures, AFAICS.

Differences may be explained by very slightly different seating of the cards in the camera slot, slightly dirty contacts on card or camera, or (god forbid) something going wrong with your A7 IV ...

I have had a slightly similar problem getting my wife's new tablet to behave with an old micro-SD card. Took three insertion/ejection cycles to get it to function properly. Hopefully, it's the card going bad, not her new tablet!


Product of the Fifties
It may have to do with Physical Block versus Logical Block on the card. The type of memory used in these cards has a limited number of write cycles. To maximize life of the card, you want to spread write cycles over the Physical blocks. Formatting will clear logical blocks. If you wrote to the same physical blocks every time you formatted the card, you would limit the lifecycle of the card. So- somewhere in the card is a table that picks out the next blocks to write to. Also tracked- bad blocks that are mapped out. I'm equating this to a disk drive that uses Logical block addressing rather than physical blocks. To get "truly meaningful" results with a card that operates like this- you would have to start with a never-used-before card for each time doing a measurement, not just reformatting it.

You should also test performance at very high-ISO. Buffering in the camera and flushing to the card can create power draw issues. This can pull down available power for the rest of the camera. It can make a difference at very high ISO where noise can creep into the system. I tend to use a slower card for High-ISO to keep the camera "steady State".
Last edited:
Very interesting. The Kingston card is brand new out of the box, the Sony cards were not. What’s interesting to me is that the Sony cards were exactly the same each time in both cameras, as was the Kingston when used in the A7RIII. The only time I saw changes was with the Kingston in the A7IV.

I was leaning toward a firmware issue. Someone on a different forum said their card speeds are all over the place in their A7IV.


Product of the Fifties
I've seen bizarre compatibility problems with SD cards, to the point that the SD Format from the SD organization can no longer format them.

I suspected the SD card was the problem, users were losing data when using with the M9. The problem was the card, not the camera. The card failed in two different cameras and the Windows machine, I had to insist that Sandisk replace it under warranty, and the second card failed. They sent me a third card. They revised the card somehow- it worked.

Often the firmware in the camera gets blamed. I've found that some manufacturers use proprietary techniques in the cards that are non-standard and cause problems. In the case of using a Sony card in a Sony camera- The firmware in the camera is probably optimized for the Sony SD card. I would stick with that.
Thanks. You make a good point about revisions. The Kingston card has been tested as a top choice for the A7 IV and a few other Sony cameras. I sent an email to their tech support yesterday and had to include the revision number. Now you’ve got me thinking that perhaps a revision has caused the problem.