Fuji X-T2 back to Fujifilm!

Mike G

All-Pro
Oct 7, 2016
West London
Mike Gorman
Sadly I have had to send my beloved X-T2 to Fuji for repair to cure randomly refusing to start necessitateing removal of the battery to get it to start! There seems to be no pattern to this annoying bug. Here's hoping Fuji can wave their magic wand for me!
 

Mike G

All-Pro
Oct 7, 2016
West London
Mike Gorman
Thanks everyone, I'm pretty sure that Fuji will sort it out. As it was/is my only camera, I'm into thumb twiddling territory for a while!

The problem seems sporadic and unpredictable, and has happened a few times, I almost decided not to send it in, because of the randomness but my warranty runs out in September so opted to send it in, hopefully they won't take too long, fingers crossed.

I recall that fellow member Iansky had the same problem on his X-T2 and got it repaired quite quickly.
 
May 31, 2017
Central Florida
Timothy Williams
Mike I saw there was a problem reported with the X T1 and also the X70 where it would power off then back on with an error message. The temporary fix was to remove the battery and also replace the SD card with a different one. Saw this last night on a you tube video of Street Shooters. The error occurred when they were filming a review with the X70 and Ricoh GR. Don't know if this is the issue you're having but hope they get you fixed up soon.
 

Mike G

All-Pro
Oct 7, 2016
West London
Mike Gorman
Tim, thanks but not the same fault. What happens seemingly randomly is that when switching on the camera is dead, requiring the battery to be removed for a few seconds and then replaced to get the camera to start! Only using genuine Fuji batteries and approved Lexar X2000 32 GB cards.
 

merlin

All-Pro
May 25, 2017
Northern New Mexico
Merlin Emrys
The reasons for lock up seem very varied, wierd!
From all the posts I have read about this issue, it would seem that Fuji has no idea what is causing it! But obviously many X-T2 users have not (so far) experienced this.

Does not, however, bode well for my X-T2 which is due to arrive within a few hours.... :(
 

Mike G

All-Pro
Oct 7, 2016
West London
Mike Gorman
Good news, today my repaired X-T2 returned to my sweaty little hands. :bravo-009:

According to the document enclosed the Main PWB was replaced as was the top plate. Also the camera firmware was updated to 2.11, so just maybe part of the problem was firmware related?

All this cost me not a penny due to the camera being just in the warranty period which runs out in September, well done Fuji. It now looks like a new camera as the top plate replacement also meant that the dials which had a dodgy numeral paint have obviously replaced when the top plate was changed. It's nice to have it back, and as a bonus it came with a 126 battery installed which I had not sent back with it. I can stop biting my fingernails now.

Once again I can go back to being a happy chappie!
 
Last edited by a moderator:

merlin

All-Pro
May 25, 2017
Northern New Mexico
Merlin Emrys
Good news, today my repaired X-T2 returned to my sweaty little hands. :bravo-009:

According to the document enclosed the Main PWB was replaced as was the top plate. Also the camera firmware was updated to 2.11, so just maybe part of the problem was firmware related?

All this cost me not a penny due to the camera being just in the warranty period which runs out in September, well done Fuji. It now looks like a new camera as the top plate replacement also meant that the dials which had a dodgy numeral paint have obviously replaced when the top plate was changed. It's nice to have it back, and as a bonus it came with a 126 battery installed which I had not sent back with it. I can stop biting my fingernails now.

Once again I can go back to being a happy chappie!
Look forward to seeing more of your wonderful photographs, now that your baby is back home! But FW 2.10 is still the latest at the Fuji website. Maybe they are about to release 2.11...
 

Latest posts

Latest threads

Top Bottom