• Cameraderie, a friendly photography forum for photographers and camera enthusiasts!
    If you are looking for critique, tips, advice, buying recommendations, or just want to talk to fellow enthusiasts then join now for free!
  • Single In July 2019 is coming! 📸
    --> Pick your gear, join the challenge! <--

Fuji X-T3 cannot connect Cam remote via Bluetooth

Ranger Rick

Regular
Mar 12, 2012
43
Tempe, AZ
Going crazy with this. Trying to connect new X-T3 with my iPhone. Bluetooth is enabled on phone. I pair the camera, and it seems to go thru completely to the final screen showing it has done that. But I cannot see the status at the bottom of the screen to actually connect- it always says Connecting. I have reset everything and even deleted/redownloaded the Cam Remote app. I never see the X0T3 show up in the list of Bluetooth devices on the phone, the app does see the iPhone (bottom of screen).

When I try to use the Browse Camera function on the iPhone, I get the "Disconnect with camera" message (whatever that means). I can however use the Remote Release Function to control the shutter.

Does anyone have any thoughts on this- I thought Bluetooth setup was supposed to be easy. I have btw used my X-t2 with wifi in the past, so I know this can work. Any help would be appreciated before they call in the men in the white coats.
Subscribe to see EXIF info for this image (if available)
Subscribe to see EXIF info for this image (if available)
Subscribe to see EXIF info for this image (if available)
 

jyc860923

Regular
Aug 29, 2018
69
Shenyang, China
I saw you were using VPN, that might be the issue. I had the same issue with X-E3 connecting to my Android phone when I was using VPN, I don't know if you can whitelist an app in iOS so that it connects directly.
 

Ranger Rick

Regular
Mar 12, 2012
43
Tempe, AZ
I saw you were using VPN, that might be the issue. I had the same issue with X-E3 connecting to my Android phone when I was using VPN, I don't know if you can whitelist an app in iOS so that it connects directly.
I disabled the VPN, and that seems to do the trick. Thank you for that suggestion! The remote operation process is so slow that I think I will just use a cheap physical remote :)
 

Latest posts

Latest threads

Top Bottom