Fuji X100 Firmware update 1.21 !!

petemasty

Regular
Location
wiltshire, UK
I've have just had a call from Fuji UK to say that Fuji (in Japan) are fully aware of the issues around 1.20 and that they are currently urgently working on a new update and are going to get it out as quickly as possible.

They called because my camera was with them for repair and they acknowledged my camera had problems with 1.20. They are reverting my camera back to 1.13 and returning it.

well, at least we know they are on the case in resolving the problems.
 

Iansky

All-Pro
Location
Cotswolds, UK
Bugger - just upgraded last night to 1.20 - I will persevere with it though as I understand the main issue with update is around the MF / AFL issues?

I do like being able to choose function associated with RAW button!

It does appear that Fuji are lsitening to users and responding accordingly, what a shame other manufacturers are not as responsive.
 

Ray Sachs

Legend
Location
Not too far from Philly
Real Name
you should be able to figure it out...
It does appear that Fuji are lsitening to users and responding accordingly, what a shame other manufacturers are not as responsive.
Agreed, and I'm also pleased. But in fairness its a bit of a double edged sword. Most other manufacturers seem to leave fewer loose ends the first time around, so there's less need. All in all, though, a great camera just getting better...

-Ray
 

petemasty

Regular
Location
wiltshire, UK
I had a chat with the Fuji chappy about much the same thing, that being, why have they released a camera that falls so short of the mark with regards to software and performance. Was it a rush job? I told him I have never had so much trouble and so many firmware updates with a camera before in my life, so why this? He actually sounded rather contrite and admitted he and Fuji were somewhat embarrassed by all this, particularly as FW 1.2 has created more problems than it has resolved. That's when he fully reassured me Fuji are working intensely on a new firmware to resolve.

We also discussed SAB, as I have only taken about 1000 shutter actuations (the days of film are still with me I'm afraid. Don't like to waste shots). My warranty is up in May but he said that if I had SAB after this time, and the camera had not been physically abused, Fuji would fix free of charge despite being outside the warranty because SAb is a known fault.

Yes, this sort of service may sound exemplary, but it shouldn't have happened in the first place. We are where we are. If we stick with the x100 the only thing we can hope for is that Fuji make this camera worth the investment made by its owners.

Let's hope in six months time, we can all cry out "we are so glad we persevered!!!,"
 

Julien

Top Veteran
Location
Paris, France
Real Name
Julien
The fuji guys twitted something about it, and when they do that the update is generally just around the corner. Tomorrow wouldn't surprise me.
 

alessandro

Regular
Location
Vicenza, Italy
It fixes what they say it fixes: the bad bug of the MF+AFL misalignment.
AF lock still unlocks when going to OVF
AF lock (AF only) still prevents exposure compensation

Nothing to regret here: they fixed the worst one in a hurry. I would expect a new update in a more reasonable time.

They need to hire an English mother tongue editor. Seen from my pidgin English point of view, their communications are funny to say the least.
 

petemasty

Regular
Location
wiltshire, UK
Well, the updates works for me. I have also noticed that it takes a mere one revolution to go from near to infinity on the manual focus ring, whereas t took two revolutions in 1.20

Let's hope this camera will get even better.
 

kevenv

Regular
I happened to be shooting a bunch of pics after upgrading and noticed that the battery indication is way more reliable than in the past. Prior to this upgrade (though it could be a result of 1.20) when the battery level turned red it would fail on me after 2-3 shots. Yesterday I got down to 1 red bar and kept shooting to see how many pics I could get. After 40 pictures it still hadn't died so I stopped. Huge improvement for me.

Maybe someone else could try and drain their battery to see if this is indeed an improvement or pure luck for me.
 

winginkris

Veteran
I happened to be shooting a bunch of pics after upgrading and noticed that the battery indication is way more reliable than in the past. Prior to this upgrade (though it could be a result of 1.20) when the battery level turned red it would fail on me after 2-3 shots. Yesterday I got down to 1 red bar and kept shooting to see how many pics I could get. After 40 pictures it still hadn't died so I stopped. Huge improvement for me.

Maybe someone else could try and drain their battery to see if this is indeed an improvement or pure luck for me.

This has been one of my minor gripes with the x100 as well. Just when I get a warning, the battery's gone. I'll try and let mine run down today and see if it's been fixed.
 

Latest posts

Latest threads

Top Bottom