Fuji X100 Off Camera Flash

JoeLopez

Veteran
May 18, 2017
69
When I use a Flash cord on the shoe of my X100 and on any speedlight, including the EF-20, I disable silent mode, Set External Flash to ON and the flash fires every time.

When I keep the same settings and use a Pocketwizard Plus X on the shoe and a Plus X on my EF-20 (with a PC Sync adapter on the flash shoe), the flash fires when I press the button on the pocketwizard every time. When the PW is on the X100 shoe, it fires sometimes and not everytime.

Anyone using wireless radio triggers on a X100/S/T care to share the camera settings?

Thanks.
Joe
 
Last edited by a moderator:

flysurfer

Hall of Famer
Aug 31, 2011
123
I use wireless on my X100F, combining EF-X500 and Metz M400 flash units, because my Godox stuff isn't working with the X100F.

100F0542
by Rico Pfirstinger, on Flickr

It works fine, but you need a camera with Fuji's current flash system, so the X100, X100S and X100T are out.

I hope Godox will update their firmware to fully support the X100 series. I really like their 2.4 GHz system. Great lineup with great value.
 

JoeLopez

Veteran
May 18, 2017
69
Thank you. Seems strange, I'd think all I need to do is turn OFF silent mode and turn ON external flash. I'll retry.
 

Matt2134

New Member
Nov 12, 2017
3
I use wireless on my X100F, combining EF-X500 and Metz M400 flash units, because my Godox stuff isn't working with the X100F.

View attachment 32522100F0542 by Rico Pfirstinger, on Flickr

It works fine, but you need a camera with Fuji's current flash system, so the X100, X100S and X100T are out.

I hope Godox will update their firmware to fully support the X100 series. I really like their 2.4 GHz system. Great lineup with great value.



They have - I just updated my godox flash and trigger with latest firmware (fiddly but manageable) and it works really well on my X100F
 

Latest posts

Latest threads

Top Bottom