XZ "issues"

Jan 31, 2011
164
Newcastle, Australia
Sue
My XZ seized up this afternoon. I went down to the beach after lunching, and tried to get some shots of some really weird clouds (they were brown instead of grey or white) and the camera just refused to work. I thought it was the battery, but it didn't actually close the lens. it just...stopped. The one shot I thought I did get, I didn't. I had to remove the battery from the body and then I put it back in and I was able to shut it down (so the lens would retract). It seems to be fine right now but I think I am going to give it a good run over the next couple of days and if it does it again, back to the reseller it goes!

Also, the lens seems noisier on opening and closing than it used to.

Any other XZ owners experiencing anything like this at all?
 

Lili

Hall of Famer
Oct 17, 2010
123
Dallas, TX
Lili
Sue I have used mine a lot and not had this issue. How much noisier is it? What type of sound? Is it different or just louder?
 
Jan 31, 2011
164
Newcastle, Australia
Sue
@Lili: kinda grinding when it opens and closes

@Kerri: When I say I was at the beach, I was on the road, near rocks. No sand really close and no, it wasnt very windy. I dont do much in extremes of wind except when the waves are up and thats always with the DSLR and WR zooms.

It might have been user error... I was just thinking I might have pressed two buttons at once and that would do it. Sometimes I find that the placement of the buttons on the rear is a bit inconvenient and my thumb strays into areas it has no business going when I am pressing the shutter release.

I'll see how it goes. The noise? Might just be my paranoia.
 

Lili

Hall of Famer
Oct 17, 2010
123
Dallas, TX
Lili
@Lili: kinda grinding when it opens and closes

@Kerri: When I say I was at the beach, I was on the road, near rocks. No sand really close and no, it wasnt very windy. I dont do much in extremes of wind except when the waves are up and thats always with the DSLR and WR zooms.

It might have been user error... I was just thinking I might have pressed two buttons at once and that would do it. Sometimes I find that the placement of the buttons on the rear is a bit inconvenient and my thumb strays into areas it has no business going when I am pressing the shutter release.

I'll see how it goes. The noise? Might just be my paranoia.

I have been there, something messes up and one hears things one does not recall. I lay the problem aside and come back much later and there is no issue. Once my Panic Ears are off that is.
 

Latest posts

Latest threads

Top Bottom